Service Interruption
Incident Report for Enigma Digital
Resolved
This incident has been resolved.
Posted 7 months ago. May 01, 2017 - 11:24 AWST
Update
Server has been rebooted and is back online now.
Posted 7 months ago. May 01, 2017 - 10:25 AWST
Investigating
Technicians are investigating... standby for updates.
Posted 7 months ago. May 01, 2017 - 10:17 AWST